Saturday, October 11, 2008

Visual Studio 2008 setup project says it requires .NET Framework 3.5

Just did my first setup project on visual studio 2008 from scratch rather than upgrade. The msi on the target machine said "this setup requires the .NET Framework version 3.5", even though the solution targets 2.0 exclusively.

Solved by right-clicking on the setup project, View, Launch Conditions. Then edit the properties of the Requirements on Target Machine=>Launch Conditions=>.NET Framework node. Default is 3.5

Upgraded setup projects defaulted to 2.0 after I selected that as the default general behavior for upgrading projects targeting 1.1

1 comment:

RayRay said...

Excellent, thanks for this. Had removed .NET Framework 3.5 from Setup Project pre-requisites and couldn't understand why I was still getting the 3.5 prompt.
Cheers.